TransUnion 3B Report Timeouts
Incident Report for Identity and Credit Services
Resolved
Reports are returning once again in a timely fashion.
Posted Oct 01, 2020 - 11:46 PDT
Investigating
Some members are currently experiencing issues pulling 3B credit reports from TransUnion. This appears to be due to timeout issues with TransUnion services. We have reported the issue to TransUnion and they are currently investigating.
Posted Oct 01, 2020 - 11:28 PDT
This incident affected: TransUnion Credit Services.