Active System Outage
Incident Report for Identity and Credit Services
Resolved
The issue has been resolved. The outage lasted for approximately 10 minutes. Thank you for your patience.

If you are experiencing issues with your service, please contact your Account Manager.
Posted Apr 02, 2021 - 08:52 PDT
Identified
IDCS is experiencing an active system outage due to a faulty networking component affecting the IDCS Core system. Engineers are actively working to restore server. During this time, all system calls and services are likely to fail.
Posted Apr 02, 2021 - 08:44 PDT
This incident affected: core.idandcredit.com - Core IDCS Platform and api.idandcredit.com - API and Hosted Portals.