Intermittent Timeouts in TransUnion Credit Services
Incident Report for Identity and Credit Services
Resolved
This has been resolved. Services are now responding normally.
Posted Sep 02, 2020 - 17:42 PDT
Identified
TransUnion is experiencing intermittent timeouts in retrieving 1B and 3B credit reports. They are currently investigating. If you experience an issue, we recommend waiting 5 minutes and re-pulling your report. We will update this notification as we receive additional information.
Posted Sep 02, 2020 - 16:37 PDT
This incident affected: TransUnion Credit Services.