TransUnion system timeouts
Incident Report for Identity and Credit Services
Resolved
This has been resolved. Services are responding normally now.
Posted Sep 05, 2020 - 15:47 PDT
Identified
TransUnion is currently experiencing a production issue causing some credit report requests to timeout. You may receive error messages as a result. TransUnion is currently working on the issue.
Posted Sep 05, 2020 - 15:03 PDT
This incident affected: TransUnion Credit Services.